User Account






Forgot your password?
Forgot your username?
No account yet? Create an account to expedite checkout and be informed about new products and the latest updates. Register Free

Download Area
Show Cart
Your Cart is currently empty.


Advanced Search

Home Forums reKon audio VST-AU Lead 2 Editor VST Lead Editor 2 - Not working
Welcome, Guest
Username: Password: Remember me
All topics relating to the VST-AU Lead 2 Editor VST, Audio Unit and Standalone application.
  • Page:
  • 1

TOPIC: VST Lead Editor 2 - Not working

VST Lead Editor 2 - Not working 4 years 3 months ago #136

  • fmacor
  • fmacor's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 1
Hi all,
i've ugraded to Nord Lead editor 2, while being very unsatisfied by nord lead editor 1.
I can say that i've been drived by the low price.
However, the editor isn't working
I'm running osx 10.7.5
Using standalone version
I have a Nord Rack 2X

The editor can send patch change but if i twist any knob, there is no change on the synth and, if i twist a knob on the synth, no change on the editor.
The MIDI MONITOR windows, reports only key pressure but no midi cc from the software.
However, in the MIDI input, i can see the MIDI CC from the synth when i move a poti.
Attached you'll find my midi setup
What can i do?
This one looked way better from the past V1, but worked so so
Also the manual was not very useful
Could you help me?

The administrator has disabled public write access.

VST Lead Editor 2 - Not working 4 years 3 months ago #138

  • lanrosta
  • lanrosta's Avatar
  • OFFLINE
  • Administrator
  • Posts: 66
You are not setting it up correctly according to the User Manual or provided instructions.

The first issue is obvious... DO NOT ACTIVATE THE PROGRAM CHANGE BUTTONS IN MIDI SETUP. We do not use program changes with the editor as it will conflict with the changes the editor is making. We are working on the edit buffer with the editor. Turn them all off (all four of them) in the MIDI Setup.

I am not sure what 'NORD RACK' is in actuality for your MIDI port, but I am going to assume it is connected to the synth for both MIDI In and Out and works fine in other MIDI/DAW apps with the Nord.

I have explained the setup process and important details for most all popular DAW hosts in the online Setup Guide. Also be sure to read the VST-AU Lead 2 User Manual to check out all the details and new features.

Here is some additional information to help you get it working correctly...


1. Open the standalone version then select the 'Menu/Settings/Device Settings' and select your audio card and channel the synth is connected to, and the remote MIDI keyboard you plan on using to play notes into the Nord (DO NOT SELECT THE MIDI PORT THE NORD LEAD IS ON!!!) Pick a separate MIDI controller for this.

2. Open the MIDI Setup and select the MIDI In and Out ports that are connected to the Nord here.

3. Now set both Editor MIDI In and Editor MIDI Out to use MIDI Channel 16 for both.

4. 4. Now set your Nord to 'Global Channel 16'. Set all the parts to MIDI Channels 1 for A, 2 for B, 3 for C, 3 for D on the Nord.

5. You do not need to change any filter checkboxes in MIDI Setup (DO NOT SELECT ANY PROGRAM CHANGE CHECKBOXES!!! WE DO NOT USE THESE WITH THE EDITOR AS THEY WILL MESS THINGS UP OR NOT SEND THE MIDI!!!)

6. Open the 'Patch Manager' and use 'File/Load Bank from FXB' to load the default 'VST-AU Lead 2 Editor.fxb' bank file.

7. Open the MIDI Monitor. Now switch patches in the Editor or Patch Manager. You should see the sysex data being sent out.

8. Check your MIDI Device to make sure the data is being sent/received to the synth.

9. If you are using the plug-in in a DAW, then you need to disable the ports in the DAW's MIDI preferences FIRST, (before instating the plug-in). Then open the plug-in, and run MIDI Setup to Setup the MIDI ports. If You do not disable the port in the DAW first, it WILL NOT WORK. Make sure you do this first. very important!


Please read ALL materials that are provided before requesting support. Also, please contact me directly for support issues like this instead of posting them on the Forum. It will make it much easier for me to help you directly with support cases.

Thank you,
lanrosta
Last Edit: 4 years 3 months ago by lanrosta.
The administrator has disabled public write access.
  • Page:
  • 1
Time to create page: 0.141 seconds