User Account






Forgot your password?
Forgot your username?
No account yet? Create an account to expedite checkout and be informed about new products and the latest updates. Register Free

Download Area
Show Cart
Your Cart is currently empty.


Advanced Search

Home Support User Manuals VST-AU Lead 2 Editor User Manual

VST-AU Lead 2 Editor™ User Manual


Note that the information found here is specific to the product and synthesizer model(s) it was made for. For information that is common and shared across all products, and for DAW Host Setup information, please see the Setup Guide. For more information regarding this product and pricing please see the Product Details page.

Table of Contents

 

Introduction

The VST-AU Lead 2 Editor™ is a real-time MIDI synth editor that allows you full control of every parameter of the sound on the Clavia Lead 2/2x and Rack 2/2x™ rack and keyboard model synthesizers. It is also a complete librarian tool that allows you to view and manage all the patch and bank data on modern computing platforms and applications, in smart and efficient ways. Now you can utilize your Nord Lead 2 to its full potential in new and interesting ways, and build lasting and meaningful patches that will bring new life to your music.

You can manage, view and edit all your patches on the computer itself without the hassle of manual dumps. All parameters are fully automatable using your favorite VST or AU capable DAW host, giving you the ability to visually program the Nord Lead 2 to your music in the host sequencer. This ability to model your synth patches in real-time, inside your main music production environment is part of what makes the VST-AU Lead 2 Editor™ unique when compared to other hardware synth editors. You may also use the standalone application if you do not need to work inside the host or if your DAW host is not supported. Please check the DAW Host Support chart on the web site product page for details.

The VST-AU Lead 2 Editor™ will be further referred to in this manual as 'Editor'. Any 32 bit or 64 bit VST or Audio Unit DAW Host will be further referred to in this manual as 'Host'. The Clavia Nord Lead/Rack 2/2x will be further referred to in this manual as 'Synth'.

This editor will work on the Clavia Nord Lead/Rack 2 and 2x rack and keyboard synthesizer models.

 

It's a Complete Synth Editor

The VST-AU Lead 2 Editor™ is a visual editor allowing you to view and edit every parameter of the Clavia Music Nord Lead 2 synthesizer. Here's just some of the amazing and useful features the Editor offers:

  • Easily see and edit all parameters of your patch in logical views with logical controls.
  • It works in real-time! Instantly hear your changes as you play. Craft your patch along with your music as you make it!
  • Parameters respond to knob movements from external and internal controllers.
  • Automate the parameters in your DAW host via physical knob movements, Editor control movements, or in the Host with the draw tool.
  • All edits and automation are remembered and sent out to the hardware when you start up your project.
  • Meticulously thought out and well designed interface and tools that are specific to the hardware model!
  • Available as a VST, Audio Unit and Standalone application.
  • Supports recent and latest versions Mac OSX and Windows in both 32 bit and 64 bit versions.
  • Endless routing possibilities allow for complex MIDI setups and use.

 

It's an Advanced Patch Librarian Manager

The VST-AU Lead 2 Editor™ includes a new advanced Patch Manager view that allows you to manage your patches and bank easily in one view. Here's just some of the amazing and useful features the Patch Manager offers:

  • Rename patches with ease.
  • Drag and drop patches or blocks from one slot to another in copy, swap or move mode.
  • Highlights other patches in the bank which are 'Duplicates by Name', and 'Exact Duplicates'.
  • Easily remove all 'Exact Duplicate' patches with one click to clear space for other patches.
  • Undo feature allows for non-destructive editing and reversing mistakes.
  • Easily copy or swap patches, blocks, or bank A and B.
  • Randomize a patch or entire banks with one click.
  • Clear patches or entire banks with one click.
  • Add/Remove a prefix name to patches or entire banks to easily identify your patches.
  • Export just the Patch names as a .txt file.
  • Import your existing patch and bank libraries via System Exclusive data dump direct from the synth, or load them in from .syx files.
  • Save as standard .fxp/.fxb files or native .syx file format.

 

Full MIDI message filtering of MIDI Input and Output data

MIDI Setup allows you to select the MIDI ports and Channels that you are using to connect to the hardware synthesizer. You can also filter specific MIDI messages from all MIDI data paths from the DAW Host, Editor and Synth. Absolute control of the data paths allow for complex MIDI setups that can be saved and loaded for specific uses and applications. By using specific MIDI Setups with different instances of the plug-in, you can now use multiple instances of the plug-in for multiple machine control.

  • Create, Load and Save MIDI Setups for instant recall of settings and multiple instance use.
  • Filter any MIDI message to/from the Synth, Editor and Host.

 

Full MIDI Input and Output Monitoring

The Midi Monitor view allows you to view all MIDI data coming in to and out of the VST-AU Lead 2 Editor™.

  • Easily switch between Input and Output views of both Host and Editor/Synth MIDI input and output data.
  • Copy the data from the event logs for pasting and saving into standard text editors or other applications.

 

Requirements

In order to use the software properly you will need the following:

  • The actual model of hardware synthesizer the product is designed for.
  • A PC computer running Windows (XP - Win7) or Mac OSX (10.6 or above).
  • An Audio Card to connect the synth to the PC audio inputs.
  • Audio cables to connect your synthesizer to the Audio Card.
  • A USB (or other) MIDI device with MIDI In and MIDI Out connectors.
  • 2 MIDI cables to connect between synth and MIDI device.
  • A reKon audio Activation Code.
  • A DAW Plug-In Host (ex. Cubase, Live, Logic) or use the Standalone version.
  • A firm understanding of MIDI, your synthesizer, its user manual, and its capabilities.
  • Some patience in getting things setup and working. This is technical MIDI routing, so take your time.
  • Double check your routings, settings and equipment.

 

Physical Connections

You will need to make the appropriate physical MIDI and audio connections to and from your hardware synthesizer and the computer first. You will also need to read and understand the user manuals for both your manufacturers hardware synthesizer, and the VST-AU Editor product you are using. Often, you will need to make some system settings on the hardware synthesizer in order to be able to send and receive MIDI data appropriately. The basic connections of a typical setup example would look like the figure below, but may also be expanded upon. In this example, a remote MIDI controller keyboard is used to play note data into the DAW, through the editor, and out to the hardware synthesizer.

 

Installation

Mac Installation

  1. Before installing the new software. First manually delete the files below (OSX has no uninstaller for applications). If you cannot find the locations above using Finder, then make absolutely sure your user account has Administrator rights and that you are showing all hidden files. You can use any search engine to find apps or tutorials on how to show hidden files on OSX. Here is the Terminal command line way to do it:

    Open Terminal and type: defaults write com.apple.finder AppleShowAllFiles TRUE

    type 'Enter' key, then, type: killall Finder.

    type 'Enter' key again.

  2. Run the .pkg installer file from the download. This will install the VST, AU and Standalone application and related files to the following folders on your computer:

    • AU 32-bit and 64-bit: /{user}/Library/Audio/Plug-Ins/Components/reKon audio/[VST-AU Editor Name]/
    • VST 32-bit and 64-bit: /{user}/Library/Audio/Plug-Ins/VST/reKon audio/[VST-AU Editor Name]/
    • Standalone: /Applications/reKon audio/[VST-AU Editor Name]/

    *Note that you may need to copy the 'VST' and 'Component' files to your '/Library/Audio/Plug-Ins/' folder for your host to be able to find them.
  3. Once installed, then first run the Standalone version so you can run the Product Activation (see below) without permission interference from a DAW. Note that the product will not allow operation without the provided license key!

 

 

Windows Installation

  1. Before installing, and if you have a previous version installed, be sure to run Windows Uninstaller and Uninstall the current version of software first. Make sure the account on your computer has Administrator privileges and that you are showing any hidden files (use File Explorer preferences).
  2. Run the .msi installer file. This will install the VST and Standalone application and related files to the following folders on your computer:

    For 32-bit Windows operating systems:
    • 32-bit VST: c:/Program Files/Common Files/VST2/reKon audio/[VST-AU Editor Name]/
    • Standalone: c:/Program Files/reKon audio/[VST-AU Editor Name]/

    For 64-bit Windows operating systems:
    • 32-bit VST: /Program Files (x86)/VSTPlugins/reKon audio/[VST-AU Editor Name]/
    • 64-bit VST: /Program Files/VSTPlugins/reKon audio/[VST-AU Editor Name]/
    • Standalone: /Program Files (x86)/reKon audio/[VST-AU Editor Name]/
  3. Once installed, then first run the Standalone version so you can run the Product Activation (see below) without permission interference from a DAW. Note that the product will not allow operation without the provided license key!

 

Product Activation

The VST-AU Editor™ series products now make Activating your product online easy. Simply follow the instructions in the Product Activation screen in the software and you'll be up and running in no time. Product Activation requires that you have an internet connection available. For DAW workstations that are offline, you may still activate the product on a computer that is not connected to the internet using the Offline Activation method, though it will take longer for us to manually process and send your license key to you (up to 48 business hours). Online activation is the easiest and quickest way to activate your product and get going with it right away.

Products can only be 'Activated' and run on a single computer at a time. Once you have activated this product on a computer, you cannot install and run it on another computer until you have successfully 'De-Activated' the product from the computer it was installed on.

To 'De-Activate' your product so that you may use it on a different computer or need to re-install it, go to your 'Account Settings/Order Details' page and click the 'De-Activate' button. Follow the instructions within the 'Product De-Activation' screen .

Note - We review ALL Product Activations and Product De-activations to verify ownership and prevent fraud!

 

 

Setting up the Synth


You will need to make a few settings on the Nord Lead/Rack 2/2x to make sure things are running properly. Make sure you have your MIDI ports and channels set up and matching properly as below, and that all cables are working and connected properly, then power on the Synth.

  • Hold the 'Shift' button down and press the 'MIDI Channel' button. Set the Global MIDI Channel to 16. Set Bank A to MIDI Channel 1, Bank B to MIDI Channel 2, Bank C to MIDI Channel 3, and Bank D to MIDI Channel 4.
  • For clock syncing, hold the 'Shift' button down and press the 'Special' button. Set the LFO and Arp syncing to whatever clock timing you wish to use. This will allow MIDI Clock sync from a clock source. (see the clock sync feature in the MIDI Setup section for more information)
  • New in version 2.1.4 is the 'Bank' selection option. It is located under the 'Model Selection' box. It is used when Importing and Exporting .syx Banks and Patches. If you have selected the 'Nord Lead 2' model, then Banks 1-4 are selectable. If you are using the 'Nord Lead 2x' model, you can select Banks 1-10.
  • Also new in version 2.1.4 is the 'secret' filter option called 'BP+LP *'. The asterisk (*) indicates that this parameter value is only transmitted by .syx patch change. Selecting it in the Editor WILL NOT SEND the change to the Nord Lead 2 because it is not natively built in to the MIDI CC command. In order to hear the change, set it to the 'BP+LP *' option, then click the 'Set Edit Buffer (set 'E') button to send the new .syx patch data to the edit buffer in the Synth. When you select a patch that already has the filter set to 'BP+HP *', the Editor will send it automatically and the Nord Lead 2 will have it set properly. You can select the 'secret' filter on the Nord Lead 2 itself by pressing and holding the 'Shift' button + pressing the 'Filter Type' button.

The 'Selected Slot' box allows you to select which 'part' your are currently playing. When you switch part slots (A-D), the Program is remembered for that part and is sent to the Synth on the selected 'Part' MIDI Channel. When using the 'Set Edit Buffer' functions, the part indicates which part edit buffer the data is sent to. The 'Selected Slot' allows you to access all four parts in your DAW within the same plug-in instance.

The 'Model Selection' box allows you to select which model Nord Lead 2 or Nord Lead 2x you are using. The 'Bank' selection will change depending on the 'Model' selection. Banks 0-3 for Nord Lead 2, and Banks 0-9 for Nord Lead 2x. The 'Bank' selection allows you to select which bank number will be used for the 'Get Patch',' Get Bank', 'Send Patch', and 'Send Bank' functions.

 

If you are using a Nord 2 model, you will need the additional PCMCIA Card to be able to access Banks 2-4. If you do not have the card, all bank selections from the Editor will be directed to 'Bank 1'.

If you are using a Nord 2x model, you are able to access Banks 1-10 by using the 'Bank' selection located in the 'Model Selection' box.

 

Using The Graphical User Interface

The graphical user interface of the VST-AU Lead 2™ Editor™ is designed for maximum ease of use, giving you easy access to all of the parameters and common functions right on one screen. You are also able to rename, modify and browse the Patches right inside the Editor itself. All controls are handled via either a slider, knob, combo box, button or text edit box.

 

The Main User Interface View

The VST-AU Lead 2™ Editor™ main screen (may or may not be shown to scale)...

  • The File menu allows you to save and load Standalone Setup files. It will recall all your patch and bank settings.
  • The Settings menu allows you to configure your Audio Card Settings and Remote MIDI keyboard controller input.
  • The Help menu provides links to online help.

From left to right in the image figure:

  1. Patch Number and Name - Shows the Patch name and Patch Number. Click on this to edit the Patch name.
  2. Arrow Up: Patch Increment - Move up one Patch.
  3. Arrow Down: Patch Decrement - Move down one Patch.
  4. COPY button: Copy this Patch to clipboard.
  5. PASTE button:  Paste from clipboard to Patch.
  6. PM button: Opens the 'Patch Manager' view (see 'Patch Manager' section).
  7. MS button: MIDI SETUP - Opens the 'MIDI Setup' view (see 'MIDI Setup' section).
  8. MM button: MIDI MONITOR - Opens the 'MIDI Monitor' view (see 'MIDI Monitor' section).
  9. C button: CLEAR PATCH - Clears the current patch.
  10. ? button: Click to randomize the Patch.
  11. U button: Undo changes.
  12. R button: Redo changes.
  13. Top E button: GET EDIT BUFFER -  Gets the current patch in the Lead 2 edit buffer.
  14. Top P button: GET PATCH - Get's the current patch on the Lead 2 program memory.
  15. Top B button: GET BANK - Opens the Patch Manager view. Use the Sync menu/Get Bank to get the bank into the editor. It will get all patches automatically.
  16. Bottom E button: SET EDIT BUFFER- Send the current patch to the Lead 2 edit buffer. Use it only if you need to 're-send' the patch.
  17. Bottom P button: SET PATCH - Send the current patch to the Lead 2. This overwrites your existing data on the synth. Use wisely!
  18. Bottom B button: SET BANK - Opens the Patch Manager view. Use the Sync menu/Get Bank to send the bank into the synth. This overwrites your existing data on the synth. Use wisely!
  19. ! button: MIDI PANIC- Click to stop all notes and all sounds (Note- may not work on some synthesizers if it is not in the synths MIDI specification).
  20. Colored MIDI LED's: These represent MIDI data that is moving in and out of the Editor from the DAW host and Editor/Synth.
  21. Product Logo: Click this to open the About screen. This screen will show you your product version, if an update is available, and your license information.

 

The 'Selected Slot' box allows you to select which 'part' your are currently playing. When you switch part slots (A-D), the Program is remembered for that part and is sent to the Synth on the selected 'Part' MIDI Channel. When using the 'Set Edit Buffer' functions, the part indicates which part edit buffer the data is sent to. The 'Selected Slot' allows you to access all four parts in your DAW within the same plug-in instance.

The 'Model Selection' box allows you to select which model Nord Lead 2 or Nord Lead 2x you are using. The 'Bank' selection will change depending on the 'Model' selection. Banks 0-3 for Nord Lead 2, and Banks 0-9 for Nord Lead 2x. The 'Bank' selection allows you to select which bank number will be used for the 'Get Patch',' Get Bank', 'Send Patch', and 'Send Bank' functions.

Some hosts do not allow plug-ins to use keystrokes on the main plug-in window. You can still use the Patch Manager to rename the Patch in this case.

Use the Mouse Scroll Wheel to increment slider and knob movements in single increments.

Double-click a slider or knob to set it to 'middle' position.

Use the arrow buttons on your keyboard to move up and down, and left and right through Patches.

 

 

The MIDI Setup View

To access the 'MIDI Setup' view, click the 'MS' button. The 'MIDI Setup' view allows you to connect and control (filter) the MIDI data coming into and out of the Editor and Host. You will need to open this view directly after instantiating the software in order to setup up communication between the Synth and Editor. Once you have done this, the software will remember your settings. You can toggle the filtering of specific MIDI data for both the Host and Editor MIDI data paths.

If you carefully inspect the diagram in the middle, you can see exactly what data gets routed where. To make things a bit easier to differentiate, there is a color coding scheme for the MIDI data. The 'MIDI Monitor' view will show messages in these same colors.

Since this software allows you to route and filter MIDI data bidirectionally, it is best to activate only the check boxes for the specific messages you require. Otherwise, it may be possible to create a MIDI feedback loop under certain circumstances. It's best to just leave them be, as they are already optimally configured for using the editor. However, it is up to the user to understand the routings and connections being made to and from the Editor and also diagnose where any problems may be occurring.

IMPORTANT NOTICE!!!The editor gets installed with the default settings shown in the image (minus the MIDI ports, of course) and you shouldn't need to change these settings unless you are absolutely sure you know what you are doing, and that you need that particular data for input or output. Do NOT turn on the Program Change options in any of the four sections. We do not use these with the Editor and they will conflict the data or prevent MIDI data transmission. Please keep them off at all times!

  • The File menu allows you to save and load MIDI Setup files. You typically will not need to use this as it has a default already.
  • The View menu provides links to About screen.
How MIDI is handled

The four sections of filters in the MIDI Setup represent the different MIDI Inputs and MIDI Outputs the Editor uses. This is data that originates from either the DAW host, the Synth, or the Editor. The editor gets installed with the default settings shown in the image (minus the MIDI ports, of course) and you shouldn't need to change these settings unless you are absolutely sure you know what you are doing, and that you need that particular data for input or output. It's best to just leave them be as they are already optimally configured for using the editor.

Here is how the four sections break out:

  1. Host MIDI In: The top-left section deals with MIDI In data that originates from the DAW host (DAW MIDI tracks, remote keyboard input, etc.). This is typically musical data such as note On/Offs, pitch bend, modulation wheel, etc. You should never send sysex data coming from the DAW host into the Editor, as most DAW's do not handle large enough sysex data formats (through plug-ins) to work properly.We also cannot use the MIDI Clock from the DAW as it is not sent through plug-ins as MIDI clock data. Instead, we know the DAW host timing info in the processing block of the plug-in and you can choose to use this info to send a 'generated' MIDI Clock signal through the 'Editor MIDI Out' and on to the hardware synth. See below for more information.
  2. Editor MIDI In: The bottom-left section deals with MIDI In data that originates from the hardware Synth. Though you can use it to bring in Note On/Off data from the synth, it is recommended that you use a separate MIDI keyboard controller to do this through the DAW MIDI track. What we want here is to receive MIDI sysex, and CC data that the editor can use to make changes. You should never send MIDI clock data coming from the Synth into the Editor.
  3. Host MIDI Out: The top-right section deals with MIDI Out data that needs to go back to the DAW host. Though you can use it to bring in Note On/Off data from the synth (also using the Editor MIDI In), it is recommended that you use a separate MIDI keyboard controller to handle Note On/Off data through the DAW MIDI track. We really do not need to send any of the MIDI data back into the DAW if we are using a remote MIDI keyboard properly. But we do have that option. Never send MIDI sysex data back to the DAW host. Hosts will differ on how and what MIDI data they can interpret and we do not need to send sysex data, or MIDI clock data to the DAW Host from the Editor under any circumstances. Please refer to your DAW host User Manual for more information on how it uses MIDI Clock sync.
  4. Editor MIDI Out: The bottom--right section deals with MIDI Out data that needs to go to the Synth. Here we will be sending most of the MIDI data to the synth including Note On/Off data from the DAW Host In, and all changes that occur inside the itself. You will likely want to keep all of these settings on (except for the Program Change). The 'Gen Clock' icon (only shown in the plug-in versions) in the 'Clock' area allows you to toggle sending a 'generated' MIDI Clock signal out to the synth. This will be the BPM tempo of the DAW host. The accuracy of the generated MIDI clock may vary depending on your setup and DAW. If you have issues with syncing, there are also other way's of getting the DAW MIDI clock sync signal to the synth that are discussed in this manual. If this method is not satisfactory for you. It is good for testing of MIDI clocks for Arpeggios, etc.

Do not turn on the Program Change check boxes! We do not use Program Changes when using an editor like this that works on the edit buffer in the synth. You can stay on the same patch on the hardware synth, and changing patches in the editor will change all the settings it needs to recreate the patch sound without changing patches on the synth at all. All of this is done in the edit buffer, so no patch change occurred, no skip in the sound, no overwritten data in the synth, and the sysex data the editor sends is not interrupted by the program change call.

  1. Host MIDI In button - Activates the Host MIDI In module. Turn this on to receive MIDI data from the Host.
  2. Host MIDI Out button - Activates the Host MIDI Out module. Turn this on to send MIDI data to the Host.
  3. Editor MIDI In button - Activates the Editor MIDI In module. Turn this on to receive MIDI data into the Editor from the Synth.
  4. Editor MIDI Out button - Activates the Editor MIDI Out module. Turn this on to send MIDI data to the Synth from the Editor.
  5. MIDI In Port - Select the MIDI port that is connected to your Synth MIDI Out port.
  6. MIDI In Channel - Select the MIDI channel that is being used with your Synth MIDI Out port.
  7. MIDI Out Port - Select the MIDI port that is connected to your Synth MIDI In port.
  8. MIDI Out Channel - Select the MIDI channel that is being used with your Synth MIDI In port.
  9. MIDI Echo - Turn this on if you want to echo MIDI data that is coming from the Synth directly back to the synth (When the synth is in 'Local Off' mode).
  10. MIDI Setup file name - Shows the current MIDI Setup file that is being used.
  11. Routing Diagram - Shows how data is routed throughout the software, including Message color codes.

 

 

The MIDI Monitor View

To access the 'MIDI Monitor' view, click the 'MM' button. The 'MIDI Monitor' allows you to view all MIDI data that is coming into or out of the Host and Editor. By default the view will show MIDI In/Out data from the Editor MIDI data path. You can switch between Host and Editor MIDI In and MIDI Out views independently. The colors of messages are related to the color coding found in the 'MIDI Setup' diagram. The 'Clear' button will clear the data in that view. The log view will show up to 1500 messages before clearing itself automatically. You can copy the data in the log view to other applications if necessary. The 'All' button will select and automatically copy to the clipboard that entire view's data. You can turn on/off the view with the button on the right.

  1. Host or Editor MIDI Input View - Switch between Host and Editor MIDI Input data views.
  2. Clear, Copy All, or a selection of data to the clipboard.
  3. Host or Editor MIDI Output View - Switch between Host and Editor MIDI Output data views.
  4. Clear, Copy All, or a selection of data to the clipboard.

Since the MIDI Monitor requires a lot of processing to redraw the lists, we recommend you only use the MIDI Monitor for trouble shooting or 'glancing' at the data. Keep it closed when not using it to improve performance.

 

 

The Patch Manager View

To access the 'Patch Manager' view, click the 'PM' button. The 'Patch Manager' allows you to load and save Patches and Banks as .FXB/.FXP files. The 'Patch Manager' also allows you to view and organize your Patches, Blocks and Banks the way you like. Patch slots and Blocks allow you to organize your Patches by simply dragging and dropping them to another block/ slot in either Swap, Copy Replace, or Move mode. To do this, click on the Patch number box (with red numbers) and while holding down the mouse button drag this Patch to another patch location by dropping it on the Patch name box. A valid drop target will be indicated by a red outline. Drag Blocks to other Block locations by clicking in the top left corner and dragging to another Block title (it will highlight with red bars). You can also double click on a Patch number to go to that Patch.

A new feature in Patch Manager version 2.0.4 is the ability to drag and drop .syx patch (not bank) files from any Finder or File Manager type application right into a Patch Manager patch slot location. This makes it very easy to load in several patches from disk to specific locations in the Patch Manager. Another new and useful feature that goes hand-in-hand with the drag and drop .syx file, is the ability to export the entire bank as individual .syx patch files to disk, and later drag and drop them in other banks. It's very easy to manage data with the Patch Manager.

 

Also added in version 2.0.4 is the ability to Clear, Randomize, and drag and drop a block to another block location using the same Copy, Move, Swap option as the patch drag and drop functionality. Blocks are the sections with the grey header bars (patches 12 - 22 for example).

The Patch Manager screen (may or may not be shown to scale)...

  • The File menu allows you to load and save files in several useful formats including .syx and .fxp/.fxb.
  • The Edit menu provides useful features like randomize, clear, and name prefix/suffix for patches or banks.
  • The Sync menu allows you to sync data between the editor and the Synth.
  • The View menu provides links to About screen.
  1. Shows the currently loaded bank file.
  2. Shows the date and time the file was loaded.
  3. Shows the date and time the file was last saved.
  4. Drag and Drop cell for a block.
  5. An unselected Patch.
  6. The Selected Patch.
  7. An unselected patch that shares the same Name and Patch Data as the selected patch.
  8. An unselected patch that shares the same Patch Data as the selected patch, but has a different Name.
  9. An unselected patch that shares the same Name as the selected patch, but has different Patch Data.
  10. The Drag and Drop mode currently in use. This applies to Blocks and Patches.

 

Working With Patches and Banks

How Patches work

A Patch in the Editor represents a Patch on the Synth. When you change Patches in the Editor, the Patch data is sent to the Synt's edit buffer in the form of MIDI CC or Sysex messages. As a result, this data is sent to the Synth, but NOT permanently stored in the Synth. This allows you to listen to Patches from the Editor while still preserving your original Patches that reside in the Synth. If you wish to store the Patch data the Editor sent the Synth, then store it on the Synth by using the Synths 'write' function (refer to the Lead 2 keyboard manual for information on how to store a Patch), or use the 'Set Patch' or 'Set Bank' methods.

Changing the Current Patch

You can double click on the patch number area to select that patch. You may also use the arrow keys on the keyboard to move up and down, and left and right through the patches.

Renaming the Current Patch

To rename your Patch, simply click on the name in the display readout and type the new name of your Patch, then hit the 'Enter' key. Use the Patch Manager to rename patches when the DAW host won't allow you to use keystrokes in the main plug-in window.

Note that Editor Patch names are limited to 16 characters, or the max number of characters supported by the synth if it uses names.

Drag and Drop Patches and Blocks

You can rearrange Patches and Blocks of patches to other Patches and Blocks using Drag and Drop methods. The Drag and Drop Mode allows you to Copy Replace, Move, or Swap Patches and Blocks. This makes building your bank up a very rapid and painless process.

Drag and Drop .syx patch files into the Patch Manager

You can Drag and Drop single .syx file patches right into any patch slot in the Patch Manager from Finder/Explorer/File Manager applications. You can export individual .syx patches, or the entire bank as individual .syx patches. This also makes building your bank up a very rapid and painless process.

What are the Colored Outlines on the Patches?

One new feature of the Patch Manager is the ability to clearly see what patches in the bank share Similar names and/or data, and the ability to easily remove them. This makes it easy for you to manage and clean up your banks with only the relevant patches. Here's what the color coding means:

  • Red Outline - This is the currently selected Patch.
  • Purple Outline - This is an unselected patch that shares the same Name and Patch Data as the selected Patch.
  • Blue Outline - This is an unselected patch that shares the same Patch Data as the selected Patch, but has a different Name.
  • Green Outline - This is an unselected patch that shares the same Name as the selected Patch, but has different Patch Data.

Use the 'Edit' Menu to 'Clear Exact Duplicates' or 'Clear Data Duplicates'.

 

Loading and Saving Sysex Patches and Banks

Loading and Saving Sysex Patches and Banks

The VST-AU Lead 2 Editor™ can load and save standard .syx (system exclusive) Patch and Bank files. This makes importing, exporting and sharing your existing Patch libraries very easy. Use the 'Patch Manager' to load and save .syx Patch or Bank files. Once you have loaded a .syx Patch or Bank, the Editor will update with the loaded settings.

 

Importing Patches and Banks into the Editor From the Synth via Sysex

You can also easily import your existing Patches and Banks directly from the Lead 2 keyboard into the Editor. There are a couple ways to do this. Choose the method below that is specific to your task.

Do not perform these tasks while running the Host sequencer. Stop the sequencer first!

Importing a single Patch (Edit Buffer to current Editor Patch):
1. Make sure you are connected bidirectionally (MIDI IN and Out to and from Synth).
2. Select the Patch on the Lead 2 keyboard that you wish to import into the Editor.
3. Click the 'Get Edit Buffer' button and the Patch will be imported into the Editor.

Importing a single Patch (Program Buffer to current Editor Patch):
1. Make sure you are connected bidirectionally (MIDI IN and Out to and from Synth).
2. Select the Patch on the Editor that you wish to import to.
3. Click the 'Patch Get' button and the Patch will be imported into the Editor.

Importing a Bank (Programs 1-40 or 1-99 into the Editor Bank):
1. Make sure you are connected bidirectionally (MIDI IN and Out to and from Synth).
2. Click on the 'Bank Get' button. A dialog will open asking if you wish to proceed.
3. It will take about 60 seconds or so to complete the dump from the Synth into the Editor. You will see the Editor MIDI In LED's lighting up as the dump is processing and the progress bar showing the transfer progress.

 

Saving Patches and Banks into the Synth via Sysex

You can 'permanently' save Patches and Banks to the synth from the Editor. Note this will overwrite your existing Patches and Bank data in the synth . Be sure to back up your existing Patches and Banks first!

Do not perform these tasks while running the Host sequencer. Stop the sequencer first!

Permanently saving a single Patch to the synth:

1. Use the synth 's 'write' capability if you wish to store a single Patch.

Permanently saving the Editor Bank to the synth:

1. Make sure you are connected bidirectionally (MIDI IN and Out to and from Synth).
2. Make sure you turn off the 'Program Change' options in the 'MIDI Setup' view first!
3. In the Editor, click the 'Bank Send' button. A dialog will open asking if you wish to proceed. Transfer takes about 20 seconds.
4. Thesynth will now have permanently stored the new Bank data from the Editor.

 

Note: A valid Nord Lead 2 Sysex Patch file is 139 bytes and is formatted according to the sysex specification found in the Nord Lead 2 User Manual. A valid Nord Lead 2 Sysex Bank file is 5560 for 40 patches, or 24391bytes for 99 patches and is formatted according to the sysex specification found in the Clavia Nord Lead 2 User Manual. The Editor will only accept .syx files that are formatted specifically for the Nord Lead 2 synthesizer.

Note this will overwrite your existing Patch and Bank data in the synth. Be sure to back up your existing Patches and Banks first! Do not perform these tasks while running the Host sequencer. Stop the sequencer first!

 

A note on Sysex MIDI and Host Plug-in Capabilities.

Sysex data from a VST or Audio Unit plug-into the DAW Host is not widely supported by most Host DAW manufactures. This is why the Editor has it's own 'built-in' MIDI ports to connect to the hardware Synth.

 

MIDI Implementation Chart

The following MIDI data is transmitted (Tx) and Received (Rx) from the Editor and may be filtered as well.

MIDI Message
Tx Rx
Channel Y Y
Mode
Y Y
Note On/Off
Y Y
Velocity Y Y
Aftertouch
Y Y
Poly Pressure
Y Y
Pitch Wheel
Y Y
Modulation (CC1)
Y Y
Continuous COntrol (CC)
Y Y
Program Change
Y Y
System Common
Y Y
System Realtime
Y Y
System Exclusive
Y Y

x = no
o = yes

For a full list of the parameters and their value ranges, please refer to the Clavia Music Lead 2™ User Manual.

 

Getting Additional Support

If you have read through all the above material and are still having issues using the software, then personal Technical Support is available. Customers will receive their first Technical Support Response for free. After the first Technical Support Response, a fee of $25 will be charged for each Technical Support Response requested. To submit a Technical Support Response, you must provide the information below along with your contact request. You will not receive a Technical Support Response if this information is not provided with your request:

  • Your Full Name
  • Your Purchase Order Number
  • The product you need support for
  • The platform you are licensed for (Mac or Windows)
  • The Audio Card and MIDI Device(s) you are using with the software
  • The DAW host name and version number you are using the software with
  • Describe the issue you are having in as much detail as possible

 

License Agreement

  • By installing and using this product you agree to the terms and conditions set forth in the License Agreement as illustrated in the installation of the software.
  • You may download, install, run and activate this software on the same, single computer, with the same Operating System, using the same hard drive, as many times as you like.
  • You may download, install, run and activate this software on a different computer, only if you have uninstalled and 'De-Activated' any prior product 'Activations' first.
  • If you need to use the software on more than one computer at a time, multi-seat, and/or multi-platform licenses are available at quantity discounted prices.
  • You may NOT share, distribute, sell, email, pirate, torrent, hack, reverse engineer, or copy this software or user account information in any way. Doing so violates your License and Use, and Terms of Service, and is also illegal.
  • You may NOT use this product in any manner that would be considered illegal, harmful, or not as intended for its purpose and use. This includes using the product with incompatible hardware or software systems.

 

1. This is an agreement between Licensor and Licensee, who is being licensed to use the named Software.

2. Licensee acknowledges that this is only a limited nonexclusive license. Licensor is and remains the owner of all titles, rights, and interests in the Software.

3. This License permits Licensee to install the Software on more than one computer system, as long as the Software will not be used on more than one computer system simultaneously. Licensee will not make copies of the Software or allow copies of the Software to be made by others, unless authorized by this License Agreement. Licensee may make copies of the Software for backup purposes only.

4. This Software is subject to a limited warranty. Licensor warrants to Licensee that the physical medium on which this Software is distributed is free from defects in materials and workmanship under normal use, the Software will perform according to its printed documentation, and to the best of Licensor's knowledge Licensee's use of this Software according to the printed documentation is not an infringement of any third party's intellectual property rights. This limited warranty lasts for a period of 365 days after delivery. To the extent permitted by law, THE ABOVE-STATED LIMITED WARRANTY REPLACES ALL OTHER WARRANTIES, EXPRESS OR IMPLIED, AND LICENSOR DISCLAIMS ALL IMPLIED WARRANTIES INCLUDING ANY IMPLIED WARRANTY OF TITLE, MERCHANTABILITY, NONINFRINGEMENT, OR OF FITNESS FOR A PARTICULAR PURPOSE. No agent of Licensor is authorized to make any other warranties or to modify this limited warranty. Any action for breach of this limited warranty must be commenced within one year of the expiration of the warranty. Because some jurisdictions do not allow any limit on the length of an implied warranty, the above limitation may not apply to this Licensee. If the law does not allow disclaimer of implied warranties, then any implied warranty is limited to 365 days after delivery of the Software to Licensee. Licensee has specific legal rights pursuant to this warranty and, depending on Licensee's jurisdiction, may have additional rights.

5. Notwithstanding the foregoing, LICENSOR IS NOT LIABLE TO LICENSEE FOR ANY DAMAGES, INCLUDING COMPENSATORY, SPECIAL, INCIDENTAL, EXEMPLARY, PUNITIVE, OR CONSEQUENTIAL DAMAGES, CONNECTED WITH OR RESULTING FROM THIS LICENSE AGREEMENT OR LICENSEE'S USE OF THIS SOFTWARE. Licensee's jurisdiction may not allow such a limitation of damages, so this limitation may not apply.

6. Licensee agrees to defend and indemnify Licensor and hold Licensor harmless from all claims, losses, damages, complaints, or expenses connected with or resulting from Licensee's business operations.

7. Licensor has the right to terminate this License Agreement and Licensee's right to use this Software upon any material breach by Licensee.

8. Licensee agrees to return to Licensor or to destroy all copies of the Software upon termination of the License.

9. This License Agreement is the entire and exclusive agreement between Licensor and Licensee regarding this Software. This License Agreement replaces and supersedes all prior negotiations, dealings, and agreements between Licensor and Licensee regarding this Software.

10. This License Agreement is valid without Licensor's signature. It becomes effective upon the earlier of Licensee's signature or Licensee's use of the Software.

 

Disclaimer

Clavia Music, and the Lead 2™ names and logos are the property of Clavia Music. Steinberg and the VST name and logos are the property of Steinberg Media, GmbH. Apple Computer and the Audio Units name and logos are the property of Apple Computer.